Author Topic: IMPORTANT: Fix MWLL Launching Incorrectly  (Read 11421 times)

0 Members and 1 Guest are viewing this topic.

Offline Defender

  • Creative Director
  • Project Director
  • Living Legend
  • *
  • Posts: 3794
  • l33tp0intz: +65535/-65535
  • CHAOTIC NEUTRAL
    • Patrick Salerno's Porfolio
IMPORTANT: Fix MWLL Launching Incorrectly
« on: December 30, 2010, 01:37:28 AM »
http://www.microsoft.com/downloads/en/details.aspx?familyid=766a6af7-ec73-40ff-b072-9112bab119c2&displaylang=en

Use the link above to download the versions below.

Download this version for 64bit Windows
vcredist_x64.exe = 64-bit

Download this version for 32bit Windows
vcredist_x86.exe = 32-bit

This issue specifically fixes issues where you cannot load MWLL correctly and Crytek loading screens rather than MWLL show at launch.

This is an update from Microsoft to the C++ compiler that requires a new DLL on everyone's system. Since this is intalled depending on certain games you have, you may or may not have this issue if you've never had a game that needed it to be installed. This is an issue we did not cause, but now know about, and can offer a solution for.

This will be also be available via AutoUpdater as of tomorrow (12/30/10) but this is an immediate, and direct link to this solution
« Last Edit: January 01, 2011, 01:17:54 PM by Seraph »
"A Goal without Vision is a Hallucination"


"An open mind is like a fortress with its gates unbarred and unguarded."

Offline ravnock

  • Bondsman
  • *
  • Posts: 1
  • l33tp0intz: +0/-0
Re: IMPORTANT: Fix MWLL Launching Incorrectly [0.4.1]
« Reply #1 on: December 30, 2010, 06:44:32 AM »
I don't know if windows hates, I'm cursed or I just didn't get the magick wand in the mail.  I have tried installing and reinstalling Crysis Wars and MWLL numerous times and the farthest I'm able to get is just past the Crysis Wars intro video.  I'm not really sure why there is a Crysis Wars vid playing after I've gone through the main menu of a Mechwarrior game, but oh well.  At any rate I am greeted with a black screen and sound after this intro video is done playing or I skip it. 

I would like to think that there is a solution to this problem, but even after installing all of the Crysis Wars updates and installing the 0.4.0 update I still get nowhere.  I'll try another clean install sometime, but even after seeing the 0.4.1 update have no effect on the problem I have my doubts.  Oh...yes I have also downloaded and installed the update to the c++ compiler and no it didn't help even after reboot.

Offline Ingrater

  • MWLL Lead Coder
  • Project Director
  • Star Colonel
  • *
  • Posts: 1292
  • l33tp0intz: +136/-0
Re: IMPORTANT: Fix MWLL Launching Incorrectly [0.4.1]
« Reply #2 on: December 30, 2010, 09:37:50 PM »
1. Install Crysis Wars (not Warhead)
2. Install Crysis Wars Patch 1.5
3. Install the vc_redist 32 or 64 bit
4. Install the 0.4.0 package
5. Launch the autoupdater and install the patch if it asks you to do so
6. Redo step 5 until there are no more patches
7. Start Wars (without MWLL)
8. Go to multiplayer -> internet game
9. Enter your warhead cd-key if you are aksed to do so
9. Create a crynet account if you don't already have one
10. Login with your crynet account
11. Join a random wars game and make shure it works
12. Quit wars
13. Launch mwll using the launcher
14. Goto internet game, join a server and have fun
There comes a point where the talking must stop, and people have to do actual work.

Offline Springer Prime

  • Recruit
  • *
  • Posts: 56
  • l33tp0intz: +1/-0
  • "'I've got better things tonight than Die.'"
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #3 on: January 11, 2011, 11:16:45 PM »
Ok I have 4.0 installed.  as directed i tried to use its auto updater.  same issue without the reporting to dev. feature.  the like you gave me to 4.1 didnt have the file(s).  also while crysis works fine I cant even play 4.0 gets a cant find Dll error. 
Springer Prime
After there was Optimus, then there was Rodimus, and then there was me.

Offline ~SJ~MetalDeath

  • Bondsman
  • *
  • Posts: 3
  • l33tp0intz: +0/-0
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #4 on: March 14, 2011, 05:40:51 PM »
have major trouble ..installed game twice on two systems one with crysis and one with war and crysis followed all instructions  game launches  but when i try to set up a lan game it crashes as soon as i click start game ??? both systems are i7 and one is quad crossfire and the some 4 way sli ....

Offline ~SJ~MetalDeath

  • Bondsman
  • *
  • Posts: 3
  • l33tp0intz: +0/-0
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #5 on: March 14, 2011, 05:51:58 PM »
both systems run crysis fine and so dose wars

Offline (TLL)Siilk

  • Techpriest software engineer
  • Apprentice Dev
  • Living Legend
  • *
  • Posts: 3059
  • l33tp0intz: +140/-7
  • A single trueborn is an army by himself
    • My facebook profile
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #6 on: March 14, 2011, 06:38:03 PM »
 By "as i click start game" you mean what, exactly? "Launch MWLL" button of the MWLL launcher? Connecting to a multiplayer server? Trying to start a single player campaign? BTW, you're know that there is no single player in the MWLL right? ;)



"This Clan posses intelligence, the burning passion of true hunters, and a spirit that serves as a beacon to the rest. I mingle my blood with the Wolves."
- ilKhan Nicholas Kerensky, Strana Mechty, 2815

Offline Hartsblade}12th VR{

  • Alphatester
  • Lance Captain
  • *
  • Posts: 666
  • l33tp0intz: +25/-0
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #7 on: March 14, 2011, 07:47:32 PM »
have major trouble ..installed game twice on two systems one with crysis and one with war and crysis followed all instructions  game launches  but when i try to set up a lan game it crashes as soon as i click start game ??? both systems are i7 and one is quad crossfire and the some 4 way sli ....

I believe that LAN games are not working after 4.0.  Can you join a multiplayer game server?

Offline Cygma

  • MWLL Developer
  • Star Colonel
  • *
  • Posts: 1498
  • l33tp0intz: +65/-1
    • 7th Regiment Wolfs Dragoons
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #8 on: March 14, 2011, 07:50:26 PM »
Starting a LAN game via the in-game menu doesn't work, use the dedicated server section in the MWLL launcher for that. You can always set a password for private games (sv_lanonly 1 in the server.cfg should also work?).
<Insert cool content here>

Offline ~SJ~MetalDeath

  • Bondsman
  • *
  • Posts: 3
  • l33tp0intz: +0/-0
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #9 on: March 15, 2011, 08:56:34 AM »
thanks for that any plans to put it back in

Offline Seraph

  • Lead Developer
  • Living Legend
  • *
  • Posts: 4183
  • l33tp0intz: +124/-1
    • The Living Legends Mercenary Unit
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #10 on: March 15, 2011, 09:53:17 AM »
thanks for that any plans to put it back in

Use the Launcher to start your own server. Just configure the server (Setup a servername) and create a level rotation, then start the server.
Seraph - "The Can Man"
In the heat of battle, legends are born ...



Offline WedsJadeFalcon

  • Bondsman
  • *
  • Posts: 1
  • l33tp0intz: +0/-0
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #11 on: April 19, 2011, 04:25:13 PM »
How I went from ripping my hair out, to MW bliss.. :D


1: Install Crysis Wars and update it to patch 1.5 (Google for a DL link)

2: Run Crysis Wars -> multi-player -> internet games. First you will be prompted for a cd-key. Then a log in: Create a Gamespy ID (You may also get shunted to MyCrysis, I made a profile there too just to be sure).

3a: Run the MW:LL installer, then go into the file directory. It will look sort of like. Electronic Arts/Crytek/Crysis Wars/Mods/Mwll. Inside that folder is one called Updates. Extract the zip inside, then cut/paste the files into the Mwll main folder (There are file folders in there that will match up to overwrite old files, you'll know what I mean when you see it).

3b: Run the MW:LL Launcher again (I did this from the Mwll folder and made a shortcut from there, as Desura seemed to just want to keep crapping itself, but got he basic install done nicely) Make sure Auto update is checked, update it until it hits version 0.4.9. You must manually do this one update version at a time... (This took ages for me with a horrid DL speed :P )

4: Run Crysis Wars: Select Mods from Left side menu. Activate MW:LL. Go to Multi-player -> Internet. Join a game, welcome to the war.

For x64 Users: Look into the Windows C++ fix for 64bit systems linked above. I ran this also.

btw Half of this insanity I had to figure out myself, you guys might want to smooth this out to increase your player base :P

Offline Cygma

  • MWLL Developer
  • Star Colonel
  • *
  • Posts: 1498
  • l33tp0intz: +65/-1
    • 7th Regiment Wolfs Dragoons
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #12 on: April 19, 2011, 10:14:18 PM »
Well... some issues are inherited from Crysis like the account handling, you shouldn't have to do 3a at all, the updater should ask you to install the x64 redist and there is an install guide in the wiki:
http://wiki.mechlivinglegends.net/index.php?title=How_to_Install_MWLL

Anyway, happy hunting and be sure to ask in the forums next time you run into trouble :)
<Insert cool content here>

Offline [GB-72AT]Praetorian

  • Bondsman
  • *
  • Posts: 4
  • l33tp0intz: +0/-0
  • Stravag!
    • Warhawk PPC (not mine but worth a look!)
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #13 on: April 22, 2011, 01:55:05 AM »
Will try the fix above next...still stuck between 0.4.0 to 0.4.1 with the updater failing...
Cry Havoc!!!!!! And let slip the Bears of War!
-Anonymous Star Colonel of CGB
RP is the skit!

Offline [GB-72AT]Praetorian

  • Bondsman
  • *
  • Posts: 4
  • l33tp0intz: +0/-0
  • Stravag!
    • Warhawk PPC (not mine but worth a look!)
Re: IMPORTANT: Fix MWLL Launching Incorrectly
« Reply #14 on: April 23, 2011, 10:51:47 PM »
Here's how I got my game to work.  Originally was getting the error from the updater going from 0.4.0 to 0.4.1

Vista 64

Deleted the "updater download file" of 0.4.1 from my Crysis Wars\Mods\Mwll\Updates  folder

then I used the direct download .zip file location (which can be navigated to from the MWLL home page) for the 0.4.1 build

After saving that .zip file to my Crysis Wars\Mods\Mwll\Updates folder, i then extracted its contents into the Crysis Wars\Mods\Mwll folder (you will have to click through "replace this file with that"...etc..." quite a bit.)

I then did the exact same (using the direct download .zip files) thing for builds 0.4.2 thru 0.4.9 and WALLA!  I was playing shortly thereafter. 

Some notes for other newbs like me *(if you are stuck like I was)

-fresh install of Crysis Wars...(I chose to put the install location completely separate from my Warhead install)
-make sure you SHUT DOWN the UPDATER before you transfer these .zip files between these folders (i had done this with it open and it erred out on me)
-make sure you open your router firewall (if it doesn't automatically ask you) to allow Crysis Wars through

Glad I'm in the war....see you on the field.  I am willing to help (very limited knowledge, but someone willing is better than noone I guess...) anyone else who is experiencing issues if you email me.  I love this MOD, and I love what these generous devs have given us. 

Anyone who has the nerve to bitch about a free MOD of THIS QUALITY is crazy, any and all bugs are worth it...big time.  And for a 39 year old guy, it beats the SHIT out of the boardgame and MW4...

Seyla!
Cry Havoc!!!!!! And let slip the Bears of War!
-Anonymous Star Colonel of CGB
RP is the skit!