Author Topic: disconnected from server  (Read 3785 times)

0 Members and 1 Guest are viewing this topic.

Offline EMORAGER

  • Bondsman
  • *
  • Posts: 3
  • l33tp0intz: +0/-0
disconnected from server
« on: December 31, 2010, 10:21:05 AM »
hello all,

i have bought crysis warhead (with crisis wars) and Crysis legally, updated all the components to the current versions like MWLL 0.4.2 an crisis to the current version.
it says it w/  the updated crisis wars and the regular crysis w/ MWLL 0.4.2

however, it still giving me the mssg like (disconnected from server) i tryed w/out firewall and still same problem.... does anyone here have a solution.. i did browse posts but didnt find anything concrete.

some pointers would be awesome, this game rules.

rager

Offline =KoS=toasterpastries

  • Alphatester
  • Lance Sergeant
  • *
  • Posts: 355
  • l33tp0intz: +28/-0
  • Unofficial hand-held portable sugar source of MWLL
Re: disconnected from server
« Reply #1 on: December 31, 2010, 10:43:40 AM »
hello all,

i have bought crysis warhead (with crisis wars) and Crysis legally

Did you buy it from Steam or a DVD copy?


"This cosmic dance of bursting decadence and withheld permissions twists all our arms collectively but.. if sweetness can win, and it can, then I'll still be here tomorrow to high-five you yesterday my friend. Peace." - The Mad Tart Toter

Offline EMORAGER

  • Bondsman
  • *
  • Posts: 3
  • l33tp0intz: +0/-0
Re: disconnected from server
« Reply #2 on: December 31, 2010, 01:57:39 PM »
hey,

i bought the dvd version on both.
crysis
crisis warhead
crisis wars

Offline Cygma

  • MWLL Developer
  • Star Colonel
  • *
  • Posts: 1498
  • l33tp0intz: +65/-0
    • 7th Regiment Wolfs Dragoons
Re: disconnected from server
« Reply #3 on: December 31, 2010, 03:06:25 PM »
Can you connect to a server in plain Wars (i.e. without the mod being loaded)? You should do this first before going into MWLL multiplayer.
<Insert cool content here>

Offline EMORAGER

  • Bondsman
  • *
  • Posts: 3
  • l33tp0intz: +0/-0
Re: disconnected from server
« Reply #4 on: December 31, 2010, 04:59:34 PM »
i created a profile in wars then played a multyplayer game with wars.. after that i started up MWLL 0.4.2 and it says disconnected from server..
same story w/ the crysis version.. everything updated to current version and taking in account the steps i needed to take...
maybe i should just redo the whole installation  ???
but hoping to find some pointers here 1st.

greetz rager

Offline Kasatka

  • Bondsman
  • *
  • Posts: 19
  • l33tp0intz: +0/-0
Re: disconnected from server
« Reply #5 on: January 01, 2011, 10:51:15 PM »
I am getting the exact same issue.
Retail copy of all 3 crysis games, installed and fully updated, modded and updated that too. CD Keys entered properly, and profiles made in vanilla launches first. Can connect in vanilla, but in the mod i am getting "disconnected from server" every time i connect to anything.

Offline rheaven

  • Bondsman
  • *
  • Posts: 5
  • l33tp0intz: +0/-0
Re: disconnected from server
« Reply #6 on: January 03, 2011, 02:06:25 PM »
I'm having the same issue.. there seem to be only a handful of servers that show up (like 5-7?).  All but one are empty and when I click on the one that has people in it, I get a server disconnected error or the connection times out... if anyone has had luck fixing this please pm me or write it up in this thread!

Offline An0maly1

  • Bondsman
  • *
  • Posts: 9
  • l33tp0intz: +0/-0
Re: disconnected from server
« Reply #7 on: January 03, 2011, 02:13:46 PM »
Same issue here. I've heard a rumor that it is an error in how a patch was installed and it could be as simple as the patch installer accidently moving a file somewhere it should not be.

Offline Seraph

  • Lead Developer
  • Living Legend
  • *
  • Posts: 4183
  • l33tp0intz: +124/-1
    • The Living Legends Mercenary Unit
Re: disconnected from server
« Reply #8 on: January 03, 2011, 02:50:45 PM »
Same issue here. I've heard a rumor that it is an error in how a patch was installed and it could be as simple as the patch installer accidently moving a file somewhere it should not be.

No, the patch didn't remove a file. Try repair build if that doesn't fix it check the Game.log for the reason why the connection failed. Also disable your Firewall if you have any or your Virus Scanner - they might be blocking your request.
Seraph - "The Can Man"
In the heat of battle, legends are born ...



Offline Rampage

  • Lance Captain
  • ***
  • Posts: 686
  • l33tp0intz: +26/-0
    • Rampage Computers
Re: disconnected from server
« Reply #9 on: January 03, 2011, 03:01:25 PM »
If you are running AVG as your virus protection that may be the problem, especially with Windows 7 64 bit. Once I dumped AVG and switched to MS Security Essentials I never had the problem you are describing again. Just a thought.

Offline rheaven

  • Bondsman
  • *
  • Posts: 5
  • l33tp0intz: +0/-0
Re: disconnected from server
« Reply #10 on: January 03, 2011, 05:49:29 PM »
I'll try troubleshooting with the ideas you've put out there, thank you all ^_^
let you all know in 8 hours or so if it works!

Offline rheaven

  • Bondsman
  • *
  • Posts: 5
  • l33tp0intz: +0/-0
Re: disconnected from server
« Reply #11 on: January 04, 2011, 01:58:00 AM »
ok well I checked the game.log and the following was what I found after getting the 'disconnect from server' error:
CGameClientChannel::Release
[Warning] Unknown command: WarningBox
[net 00:40:55.293] connection requested to: 64.94.100.239:64087
[net 00:40:55.294] resolved as: 64.94.100.239:64087
[net 00:40:55.592] Disconnect c-64-94-100-239.internap-la.nfoservers.com:64087; profid=0; cause=1; msg='Malformed packet'
[Error] <Flash> Error: Can't find method 'setResumeEnabled' to invoke. [Libs/UI/Menus_StartMenu.gfx]
CGameClientChannel::Release
[Warning] Unknown command: WarningBox
[Error] <Flash> Error: CallMethod - 'gotoAndPlay' on invalid object. [Libs/UI/Menus_StartMenu.gfx]
System:Quit


This is a chunk of it.. I've repaired the build as previously mentioned earlier and get the same 'disconnect from server' error.

Offline Nytmare

  • Recruit
  • *
  • Posts: 76
  • l33tp0intz: +4/-0
Re: disconnected from server
« Reply #12 on: January 04, 2011, 04:21:27 AM »
Getting the same error....so very interested in this thread  :-[

Can connect to a server in Vanilla 1.5 Wars. Trying to connect in MWLL 4.3 get the same error...."cause=1; msg='Malformed packet' "


NBT-Mercs Clan Smoke Jaguar
NBT-HC Clan Star Adder
Fatty mech connoisseur

Offline Nytmare

  • Recruit
  • *
  • Posts: 76
  • l33tp0intz: +4/-0
Re: disconnected from server
« Reply #13 on: January 04, 2011, 06:38:02 AM »
SOLUTION......at least for me         :)
   
Applied the vcredist_x64.exe = 64-bit patch as per the "IMPORTANT: Fix MWLL Launching Incorrectly" post
(sticky top of Known Issues Forum).

This corrected the "disconnected from server" error (...."cause=1; msg='Malformed packet' ")


Not sure if it is relevent but....prior to the above fix patch, the loaded MWLL Wars Menu did not list 4.3 on the bottom right of the Menu screen (showed 1.xxxx?).

After the patch, it lists the correct MWLL 4.3 version number.

NBT-Mercs Clan Smoke Jaguar
NBT-HC Clan Star Adder
Fatty mech connoisseur

Offline An0maly1

  • Bondsman
  • *
  • Posts: 9
  • l33tp0intz: +0/-0
Re: disconnected from server
« Reply #14 on: January 08, 2011, 05:31:11 AM »
I just did the fix the above post suggested and it works