Author Topic: Unresponsive Controls - Can't Play  (Read 1570 times)

0 Members and 1 Guest are viewing this topic.

Offline Steph

  • Bondsman
  • *
  • Posts: 2
  • l33tp0intz: +1/-0
Unresponsive Controls - Can't Play
« on: October 22, 2013, 10:49:17 AM »
Here's hoping someone still reads this subforum...

When I join a server and spawn in a base, Nightvision mode toggles on and off endlessly. Keyboard controls don't respond, but this might be because there's an All chat input stuck open that I can't seem to dismiss. I can type things into it and send the messages, but the input line pops right back up again.

Meanwhile, Nightvision keeps switching on and off with no input from me, and this causes the game to lag out such that I have to mash Esc and pray I hit it at the right time. If I do, the game menu comes up and everything's fine. Until I dismiss the menu and return to the game, then see paragraph 1.

Notably, this occurs even if Nightvision and All chat are not bound to any inputs. I've even tested it using an Actionmapper profile that had no control bindings at all - which begs the question, if there are no control bindings, what's toggling Nightvision mode?

This is on a fresh install of 0.7.1, I've wiped it and Wars clean and done a complete reinstall of both, tried the Complete installer with the Trial version, even done a manual(!?) patch all the way from 0.6.0. I'm at a loss.
« Last Edit: October 22, 2013, 11:27:31 AM by Steph »

Offline ~SJ~ Atlessa

  • Star Captain
  • ***
  • Posts: 991
  • l33tp0intz: +80/-1
Re: Unresponsive Controls - Can't Play
« Reply #1 on: October 22, 2013, 05:14:42 PM »
Try unplugging all USB devices.

ALL!!

Including Printer, Scanner, external HDD, external 5.25" floppy, USB-Office-missile-launcher.

ALL!


Then report back.


In soviet clanspace, trinary bids you.

Offline Bruno_007

  • Apprentice Dev
  • Star Captain
  • *
  • Posts: 833
  • l33tp0intz: +90/-0
  • Osiris hats: sold out. ~Str1k3r
Re: Unresponsive Controls - Can't Play
« Reply #2 on: October 22, 2013, 05:38:05 PM »
Here, check my reply: http://forum.mechlivinglegends.net/index.php/topic,19248.msg343676.html#msg343676

I and other user had that problem, because of a virtual joystick/gamepad we were using.
Tools and I:
   - MWLL Online Launcher (LAN UDP Forwarder) - evolution of past "Le Proof of Concepto" project: connect without Gamespy via packet redirection;
   - Vehicle Browser - "Pocket Wiki" Šokaolias (not really that though);
   - Rconnect 4.3 - Server tools: map manager/player voting add-ons;
   - CryHammer - Validates Patch/CDKey of Crysis Wars (now unable to validate CDKey due to turned off Gamespy servers).

Offline Steph

  • Bondsman
  • *
  • Posts: 2
  • l33tp0intz: +1/-0
Re: Unresponsive Controls - Can't Play
« Reply #3 on: October 22, 2013, 10:16:42 PM »
Here, check my reply: http://forum.mechlivinglegends.net/index.php/topic,19248.msg343676.html#msg343676

I and other user had that problem, because of a virtual joystick/gamepad we were using.



Turns out I too had Vjoy installed. Uninstalled, no more issue. Thanks!