Author Topic: Setting up my controls  (Read 792 times)

0 Members and 1 Guest are viewing this topic.

Offline Tibrojo

  • Bondsman
  • *
  • Posts: 35
  • l33tp0intz: +0/-0
Setting up my controls
« on: July 05, 2015, 11:32:30 PM »
Hi all,
I have been working on the control mapper for a week or so and I have a few issues that I need help with.  I am trying to use a joystick.  Honestly, I dont want to play if I have to drive the mech with a mouse and keyboard.

Mainly, I cant get my torso controls to work.  I can drive the feet with z axis twist on the joystick and found if I switch my MS Sidewinder to raw input on the mapper it will work throttle as well.  However, when I try to use the X and Y input for torso twist up and down it moves slightly or kind of quivers. 
I thought maybe it was the joystick so I connected a MS Xbox 360 gamepad made for the PC and set the mapper settings for gamepad and it still does exactly the same thing.

Now the weird thing is that these same controls in question on the battlemech work perfectly for the tanks and aeros.  Man, I am inverted between buildings and shooting radar towers and using the throttle perfectly.  I can drive the tanks and move both the base and turrets just fine.    WHY??????

I would think that if one would work they all would??  Could anyone help me or give advice please?
A flying machine stays in the air because it doesnt have time to fall.

Offline Vic-Viper.v1

  • Moderator
  • Recruit
  • *
  • Posts: 96
  • l33tp0intz: +15/-3
Re: Setting up my controls
« Reply #1 on: July 06, 2015, 06:43:51 AM »
In the Action mapper of the MWLL launcher you will have to Click on the "Mech" tab select the Axis controls each , and to the right change the key binding to "JoyStick" or for the xbox controller "Gamepad" then set up your Axis's

Offline b0bgeld0f

  • Recruit
  • *
  • Posts: 157
  • l33tp0intz: +33/-2
Re: Setting up my controls
« Reply #2 on: July 06, 2015, 04:28:37 PM »
When you're in game try setting your reticule to locked.
You can do this by opening the console (tilda) and typing:
cl_fre (use tab to auto complete) set to 1 and hit enter.