Author Topic: DLL Error  (Read 402 times)

0 Members and 1 Guest are viewing this topic.

Offline thompson10

  • Bondsman
  • *
  • Posts: 2
  • l33tp0intz: +0/-0
DLL Error
« on: January 18, 2017, 05:26:39 AM »
Please help, got a "d3dx9_34.dll is either not designed to run on windows or it contains an error", error.  I tried reinstalling. I tried using the Direct X end user run time updater.  Running Crysis Wars v.1.5.0 and MWLL v 0.8.0.   Windows 10 64-bit, Direct X 12.  I am not very familiar with how to fix this, so again any help is appreciated.  Thanks!

Thompson10

Offline [IPA] Avatar

  • MechWarrior
  • **
  • Posts: 229
  • l33tp0intz: +32/-4
  • Kiss me, I'm shitfaced!
Re: DLL Error
« Reply #1 on: January 18, 2017, 09:43:05 AM »
You've got to tick the "Force DirectX 9 Mode" box in the launcher.

Offline cest73

  • Lance Captain
  • ***
  • Posts: 717
  • l33tp0intz: +21/-15
  • there are links in my signature -->
    • MW:LL game status online (kudos: Spooky)
Re: DLL Error
« Reply #2 on: January 18, 2017, 09:45:14 AM »
Hello Thompson10,
welcome to the forums.

This game/mod really uses either DX9 or DX10
This can be selected on the provided launcher.
Further a 32bit or 64bit client can be run (yes the game is this old ;) )

Could You try if switching DX to 9 or 10 changes anything?

The DX12 shipped with W10 maybe breaks some legacy support, and we well might be one?

There are more knowledgeable players to address You shortly, and they most certainly will ask You the same?
IPA_avatar beat me to the clock :)

Offline thompson10

  • Bondsman
  • *
  • Posts: 2
  • l33tp0intz: +0/-0
Re: DLL Error
« Reply #3 on: January 22, 2017, 02:28:11 AM »
I tried to launch with forcing direct x 9 and all the other options in the launcher, nothing seemed to fix the issue.  Wondering if the new 8.2 release will fix this

Offline HAARP

  • Living Legend
  • *******
  • Posts: 2332
  • l33tp0intz: +212/-1
  • I regret nothing
    • Clan Jade Wolf
Re: DLL Error
« Reply #4 on: January 22, 2017, 12:00:18 PM »
You should be using 0.8.2 already.

Anyway, since this is clearly a dx problem, you might need to try a different dx installer. It sounds like whatever it installed previously is broken.
don't bother sending me PMs, I probably won't be reading them in time.