MechWarrior: Living Legends

Beta Discussion => Dedicated Server Discussion => Topic started by: RDL_Vitos on February 17, 2014, 08:19:04 AM

Title: Setting server up NAT
Post by: RDL_Vitos on February 17, 2014, 08:19:04 AM
Question: "What needs to configure the router to run the server (IP 192.168.xx) from under NAT".
Title: Re: Setting server up NAT
Post by: Bruno_007 on February 17, 2014, 08:54:04 AM
In general terms, make it so that the public IP you get from your ISP points to the private IP of your PC that the router gives you. And configuring that would depend from router to router. Search for a DMZ setting or Default Server thing on your router, or look on the internet/manual how you could accomplish that with your router.

I think it wouldn't work otherwise for hosting a server and people being able to join it, but it could as well do since gamespy works around NAT in some degree.

Then, make sure these ports are open: http://www.crydev.net/wiki/index.php?title=Crysis_Wars_Server_Documentation&oldid=21025#Game_Port.28s.29 (and block 29910 UDP if you want a no CD-Key check server)
Title: Re: Setting server up NAT
Post by: Xarg Talasko on February 17, 2014, 11:06:59 AM
It might be called something like Port Forwarding in your router. (NOT port MAPPING, found that out the hard way)
Title: Re: Setting server up NAT
Post by: HAARP on February 17, 2014, 03:26:49 PM
Nothing. Gayspy handles NAT properly. No ports need to be forwarded.

You will however not be able to see the server's ping if it's behind a NAT. DMZ might help, but it defeats half the point of having NAT.
Title: Re: Setting server up NAT
Post by: RDL_Vitos on February 20, 2014, 10:01:53 PM
Which exactly ports you are forwarding ( opening ) on the PC ?
Title: Re: Setting server up NAT
Post by: Starch1ld on February 21, 2014, 01:44:27 AM
Which exactly ports you are forwarding ( opening ) on the PC ?
Game client doesn't need port forwarding. Just open the game and connect to a server. If you get timeout to a specific server, try to ping the server address using command prompt. If that address is unreachable, then there could be some routing problems outside your network, or some ISP blocks.

Server hosters, instead, need to port forward the same port as specified in "sv_port" parameter (usually 64100 or 64097), set in server.cfg

If they want to enable remote management, they should also port forward the port specified in "rcon_startserver port:" parameter. (use "http_startserver port:" if you want to use Str1k3r's rCon tool),

Server admin can decide both ports editing server.cfg

I'm hosting 2 servers behind a NAT, only thing I did is to port forward just 2 ports (+ 2 for rcon management) and the only problem I got is that some people just can't connect. But that is only because of ISP blocks AFAIK. Nothing I can do.