Author Topic: MW3 running on w7 64 and ati 6950  (Read 10573 times)

0 Members and 1 Guest are viewing this topic.

Offline Xarg Talasko

  • Living Legend
  • *******
  • Posts: 2960
  • l33tp0intz: +159/-6
  • KANE LIVES!
Re: MW3 running on w7 64 and ati 6950
« Reply #15 on: August 24, 2012, 05:28:56 AM »
That is indeed very helpful, thanks for taking the time to do it :)

I'll be sure to spam this thread with all my success.

Please do, I used to try to get this to work a while back. Couldn't stop both the pixel smearing and the APC's that would like to bounce like basketballs around the map.

So I gave up after getting my ass kicked by the Clanner version of the Globe Trotters.

Would someone mind posting on how to fix the blasted APC issue. I cannot figure out how to make a profile in CCC to either over/underclock my 5700 to make it work properly.

Have you tried manually underclocking the GPU?

Edit: MW3 released in 1999, the best cards around at that time iirc for ATi were the Radeon 9xxx cards, try underclocking your 57xx down to Radeon 9600 levels? That's about 300mhz core and 200mhz vram
« Last Edit: August 24, 2012, 05:36:47 AM by ~SJ~ Xarg Talasko »


Thief gameplay + Doom3 engine = The Dark Mod

Offline Errodien Ward

  • Alphatester
  • MechWarrior
  • *
  • Posts: 343
  • l33tp0intz: +56/-0
  • Delicious...
Re: MW3 running on w7 64 and ati 6950
« Reply #16 on: August 24, 2012, 05:36:21 PM »
Failure!

Still getting funky pixels in Instant Action.

did not try to check the APC issue yet.

Offline Perigren

  • Alphatester
  • Lance Sergeant
  • *
  • Posts: 378
  • l33tp0intz: +10/-0
  • Eh?
Re: MW3 running on w7 64 and ati 6950
« Reply #17 on: August 24, 2012, 06:11:23 PM »
did update your drivers? my install did not work either,even with the ati fix. then I updated the ccc software/drivers and it worked. :o
AMD Phenom II x6 1090T BE @ 3.2 Ghz,ZALMAN CNPS9900MAX-B 135mm Long life bearing CPU Cooler
ASUS M4A89TD PRO/USB3 AM3 AMD 890FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard
CORSAIR XMS3 8GB (4 x 2GB)  DDR3 1333
MSI R6950 Twin Frozr III PE/OC Radeon HD 6950 2GB 256-bit GDDR5, 2x 21.5" Samsung LED monitors(BX-2231)
COOLER MASTER HAF 932 full ATX case
Kingston 96 Gb SSD, Western Digital Caviar Black 500GB 7200 RPM SATA III
Win 7 Ultimate 64 bit

Offline Errodien Ward

  • Alphatester
  • MechWarrior
  • *
  • Posts: 343
  • l33tp0intz: +56/-0
  • Delicious...
Re: MW3 running on w7 64 and ati 6950
« Reply #18 on: August 24, 2012, 07:08:02 PM »
Yes. They are updated to current afaik.

Offline Perigren

  • Alphatester
  • Lance Sergeant
  • *
  • Posts: 378
  • l33tp0intz: +10/-0
  • Eh?
Re: MW3 running on w7 64 and ati 6950
« Reply #19 on: August 24, 2012, 07:47:07 PM »
All I can say is that every system is different and may require slightly different tweaks from one to the next. Keep trying, also did you set up a profile for mw3 in ccc and point the profile path to the mw3 exe? also if you set up a profile for mw3 and pointed the path correctly and then applied the rex fix, you will need to point the profile path to the new exe.
AMD Phenom II x6 1090T BE @ 3.2 Ghz,ZALMAN CNPS9900MAX-B 135mm Long life bearing CPU Cooler
ASUS M4A89TD PRO/USB3 AM3 AMD 890FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard
CORSAIR XMS3 8GB (4 x 2GB)  DDR3 1333
MSI R6950 Twin Frozr III PE/OC Radeon HD 6950 2GB 256-bit GDDR5, 2x 21.5" Samsung LED monitors(BX-2231)
COOLER MASTER HAF 932 full ATX case
Kingston 96 Gb SSD, Western Digital Caviar Black 500GB 7200 RPM SATA III
Win 7 Ultimate 64 bit

Offline Errodien Ward

  • Alphatester
  • MechWarrior
  • *
  • Posts: 343
  • l33tp0intz: +56/-0
  • Delicious...
Re: MW3 running on w7 64 and ati 6950
« Reply #20 on: August 24, 2012, 09:38:02 PM »
Yeah, I applied the CCC after I used the res fix.

Offline Perigren

  • Alphatester
  • Lance Sergeant
  • *
  • Posts: 378
  • l33tp0intz: +10/-0
  • Eh?
Re: MW3 running on w7 64 and ati 6950
« Reply #21 on: August 25, 2012, 04:15:53 PM »
Here is a screenie of my ccc settings for mw3, as you can see my recollection about v-sync was wrong, I thought it needed to be off when in fact always on is the setting.

I also set the gpu clock and gpu mem clock setting to the minimum in ccc
« Last Edit: August 25, 2012, 04:21:41 PM by Perigren »
AMD Phenom II x6 1090T BE @ 3.2 Ghz,ZALMAN CNPS9900MAX-B 135mm Long life bearing CPU Cooler
ASUS M4A89TD PRO/USB3 AM3 AMD 890FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard
CORSAIR XMS3 8GB (4 x 2GB)  DDR3 1333
MSI R6950 Twin Frozr III PE/OC Radeon HD 6950 2GB 256-bit GDDR5, 2x 21.5" Samsung LED monitors(BX-2231)
COOLER MASTER HAF 932 full ATX case
Kingston 96 Gb SSD, Western Digital Caviar Black 500GB 7200 RPM SATA III
Win 7 Ultimate 64 bit

Offline CapperDeluxe

  • MWLL Developer
  • Living Legend
  • *
  • Posts: 2910
  • l33tp0intz: +162/-0
  • Life is cheap, mechs are expensive.
Re: MW3 running on w7 64 and ati 6950
« Reply #22 on: August 25, 2012, 06:03:36 PM »
i've got the graphics problems fixed, but I still can't resolve the issue with the jeeps and sometimes myself bouncing up in to the atmosphere. I try setting teh affinity of the process to only 1 of my cores, and set to Low priority, and downclocked my 5850 as far as it can go. Anything else I can try?

Offline Perigren

  • Alphatester
  • Lance Sergeant
  • *
  • Posts: 378
  • l33tp0intz: +10/-0
  • Eh?
Re: MW3 running on w7 64 and ati 6950
« Reply #23 on: August 25, 2012, 06:23:56 PM »
See the screen shots I posted. Also make sure your monitor is set for 60hz refresh rate.
AMD Phenom II x6 1090T BE @ 3.2 Ghz,ZALMAN CNPS9900MAX-B 135mm Long life bearing CPU Cooler
ASUS M4A89TD PRO/USB3 AM3 AMD 890FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard
CORSAIR XMS3 8GB (4 x 2GB)  DDR3 1333
MSI R6950 Twin Frozr III PE/OC Radeon HD 6950 2GB 256-bit GDDR5, 2x 21.5" Samsung LED monitors(BX-2231)
COOLER MASTER HAF 932 full ATX case
Kingston 96 Gb SSD, Western Digital Caviar Black 500GB 7200 RPM SATA III
Win 7 Ultimate 64 bit

Offline Errodien Ward

  • Alphatester
  • MechWarrior
  • *
  • Posts: 343
  • l33tp0intz: +56/-0
  • Delicious...
Re: MW3 running on w7 64 and ati 6950
« Reply #24 on: August 25, 2012, 08:48:07 PM »
OK. did that. Now instead of smearing, I have rainbow textures and still pixelation.


Offline Perigren

  • Alphatester
  • Lance Sergeant
  • *
  • Posts: 378
  • l33tp0intz: +10/-0
  • Eh?
Re: MW3 running on w7 64 and ati 6950
« Reply #25 on: August 25, 2012, 09:03:13 PM »
Reapply the ATI fix.
AMD Phenom II x6 1090T BE @ 3.2 Ghz,ZALMAN CNPS9900MAX-B 135mm Long life bearing CPU Cooler
ASUS M4A89TD PRO/USB3 AM3 AMD 890FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard
CORSAIR XMS3 8GB (4 x 2GB)  DDR3 1333
MSI R6950 Twin Frozr III PE/OC Radeon HD 6950 2GB 256-bit GDDR5, 2x 21.5" Samsung LED monitors(BX-2231)
COOLER MASTER HAF 932 full ATX case
Kingston 96 Gb SSD, Western Digital Caviar Black 500GB 7200 RPM SATA III
Win 7 Ultimate 64 bit

Offline Errodien Ward

  • Alphatester
  • MechWarrior
  • *
  • Posts: 343
  • l33tp0intz: +56/-0
  • Delicious...
Re: MW3 running on w7 64 and ati 6950
« Reply #26 on: August 25, 2012, 10:33:20 PM »
Fixed the Rainbow, just pixels now.

Offline Perigren

  • Alphatester
  • Lance Sergeant
  • *
  • Posts: 378
  • l33tp0intz: +10/-0
  • Eh?
Re: MW3 running on w7 64 and ati 6950
« Reply #27 on: August 25, 2012, 10:35:07 PM »
Post a screen shot of what you mean by pixels?
AMD Phenom II x6 1090T BE @ 3.2 Ghz,ZALMAN CNPS9900MAX-B 135mm Long life bearing CPU Cooler
ASUS M4A89TD PRO/USB3 AM3 AMD 890FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard
CORSAIR XMS3 8GB (4 x 2GB)  DDR3 1333
MSI R6950 Twin Frozr III PE/OC Radeon HD 6950 2GB 256-bit GDDR5, 2x 21.5" Samsung LED monitors(BX-2231)
COOLER MASTER HAF 932 full ATX case
Kingston 96 Gb SSD, Western Digital Caviar Black 500GB 7200 RPM SATA III
Win 7 Ultimate 64 bit

Offline Errodien Ward

  • Alphatester
  • MechWarrior
  • *
  • Posts: 343
  • l33tp0intz: +56/-0
  • Delicious...
Re: MW3 running on w7 64 and ati 6950
« Reply #28 on: August 25, 2012, 10:40:57 PM »



I got shot by a PPC, hence the blue pixels.

Offline Perigren

  • Alphatester
  • Lance Sergeant
  • *
  • Posts: 378
  • l33tp0intz: +10/-0
  • Eh?
Re: MW3 running on w7 64 and ati 6950
« Reply #29 on: August 25, 2012, 10:44:30 PM »
What is your monitor set at for rez and refresh vs in game settings? I recall having this issue with mw3 but do not remember how I fixed it. I am however currently working on a similar issue with Pirates Moon.
AMD Phenom II x6 1090T BE @ 3.2 Ghz,ZALMAN CNPS9900MAX-B 135mm Long life bearing CPU Cooler
ASUS M4A89TD PRO/USB3 AM3 AMD 890FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard
CORSAIR XMS3 8GB (4 x 2GB)  DDR3 1333
MSI R6950 Twin Frozr III PE/OC Radeon HD 6950 2GB 256-bit GDDR5, 2x 21.5" Samsung LED monitors(BX-2231)
COOLER MASTER HAF 932 full ATX case
Kingston 96 Gb SSD, Western Digital Caviar Black 500GB 7200 RPM SATA III
Win 7 Ultimate 64 bit