Author Topic: Disconnected from server every 9min.  (Read 1907 times)

0 Members and 1 Guest are viewing this topic.

Offline [CW]Aresye

  • Star Captain
  • ***
  • Posts: 1005
  • l33tp0intz: +156/-1
  • Clan Wolf
    • Clan Wolf
Disconnected from server every 9min.
« on: August 29, 2014, 11:36:11 AM »
I just started playing MWLL again, after applying the GameSpy fix, but I'm having a weird issue that I've never had before with MWLL, and I "think" it might have something to do with the fix, but I'm not sure.

I've tested out multiple servers.  Servers with players, servers with no players, Funbox, Huntress, etc.  Every 9min, like clockwork, I get kicked back to the main menu with a, "Disconnected from Server," error message.

Has anybody experienced this particular bug before, or know what the reasons are that might be causing it?

So far I've tried:
- Disabling nVidia Shadowplay
- Disabling anti-virus.
- Connecting through a VPN.
- Disconnecting from Dropbox and Google Drive.

Offline Bruno_007

  • Apprentice Dev
  • Star Captain
  • *
  • Posts: 833
  • l33tp0intz: +90/-0
  • Osiris hats: sold out. ~Str1k3r
Re: Disconnected from server every 9min.
« Reply #1 on: August 29, 2014, 12:50:23 PM »
Have you checked the Game.log file? Might (or might not) shed some more light on the issue. Look for the reason of the disconnect.
Tools and I:
   - MWLL Online Launcher (LAN UDP Forwarder) - evolution of past "Le Proof of Concepto" project: connect without Gamespy via packet redirection;
   - Vehicle Browser - "Pocket Wiki" ©okaolias (not really that though);
   - Rconnect 4.3 - Server tools: map manager/player voting add-ons;
   - CryHammer - Validates Patch/CDKey of Crysis Wars (now unable to validate CDKey due to turned off Gamespy servers).

Offline RDL_Vitos

  • Apprentice Dev
  • Lance Captain
  • *
  • Posts: 738
  • l33tp0intz: +33/-3
  • RDL. Mechwarrior <TAU> (Clan Nova Cat) Heavy Arms
Re: Disconnected from server every 9min.
« Reply #2 on: August 29, 2014, 04:05:58 PM »
can help you:

Control Panel \ All Control Panel Items \ Administrative Tools \ Service - disable the superfetch service

Offline [CW]Aresye

  • Star Captain
  • ***
  • Posts: 1005
  • l33tp0intz: +156/-1
  • Clan Wolf
    • Clan Wolf
Re: Disconnected from server every 9min.
« Reply #3 on: August 29, 2014, 08:48:14 PM »
I'll try disabling the superfetch service.

Here's the game log:
Code: [Select]
BackupNameAttachment=" Build(6729) Date(29 Aug 2014) Time(02 08 17)"  -- used by backup system
 
Log Started at Friday, August 29, 2014 02:08:17
Running 64 bit version
Executable: C:\Program Files (x86)\Electronic Arts\Crytek\Crysis Wars\Bin64\Crysis.exe
FileVersion: 1.1.1.6729
ProductVersion: 1.1.1.6729
Using STLport C++ Standard Library implementation
 
Added MOD directory <Mods\MWLL\> to CryPak
--- CPU detection ---
Total number of logical processors: 8
Number of available logical processors: 8

Processor 0:
CPU: Intel        Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Family: 6, Model: 10, Stepping: 7
FPU: On-Chip
CPU Speed (estimated): 3502.661785 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 1:
CPU: Intel        Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Family: 6, Model: 10, Stepping: 7
FPU: On-Chip
CPU Speed (estimated): 3502.662167 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 2:
CPU: Intel        Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Family: 6, Model: 10, Stepping: 7
FPU: On-Chip
CPU Speed (estimated): 3502.657309 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 3:
CPU: Intel        Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Family: 6, Model: 10, Stepping: 7
FPU: On-Chip
CPU Speed (estimated): 3502.667420 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 4:
CPU: Intel        Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Family: 6, Model: 10, Stepping: 7
FPU: On-Chip
CPU Speed (estimated): 3502.671815 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 5:
CPU: Intel        Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Family: 6, Model: 10, Stepping: 7
FPU: On-Chip
CPU Speed (estimated): 3502.668053 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 6:
CPU: Intel        Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Family: 6, Model: 10, Stepping: 7
FPU: On-Chip
CPU Speed (estimated): 3502.672495 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 7:
CPU: Intel        Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Family: 6, Model: 10, Stepping: 7
FPU: On-Chip
CPU Speed (estimated): 3502.660631 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Total number of system cores: 4
Number of cores available to process: 4
---------------------
Windows 64 bit SP 1 (build 6.1.7601)
System language: English
Windows Directory: "C:\Windows"
Prerequisites...
* Installation of KB940105 hotfix required: no! (either not needed or already installed)
Local time is 02:08:18 08/29/14, system running for 49 minutes
16361MB physical memory installed, 13719MB available, 8388607MB virtual memory installed, 16 percent of memory in use
PageFile usage: 28MB, Working Set: 8MB, Peak PageFile usage: 28MB,
Current display mode is 1920x1080x32, (Unknown graphics card)
IBM enhanced (101/102-key) keyboard and 8+ button mouse installed
--------------------------------------------------------------------------------
Stream Engine Initialization
Network initialization
[net] using iocp socket io management
Physics initialization
MovieSystem initialization
Renderer initialization
Console initialization
Time initialization
Input initialization
Sound initialization
Sound - initializing AudioDevice now!
Sound - starting to initialize Windows Audio Session API output!
Sound - 4 drivers found:
Sound - available drivers: 0 Speakers (Realtek High Definition Audio) !
Sound - available drivers: 1 ASUS VH238-4 (NVIDIA High Definition Audio) !
Sound - available drivers: 2 Realtek Digital Output (Realtek High Definition Audio) !
Sound - available drivers: 3 Realtek Digital Output(Optical) (Realtek High Definition Audio) !
Sound - initializing FMOD-EX now!
Sound - initialized FMOD-EX
Sound - available record drivers: 0 Stereo Mix (Realtek High Definition Audio) !
Sound - using FMOD version: 00041403 and internal 00041403!
Sound - initializing SoundSystem now!
Font initialization
AI initialization
Initializing Animation System
Initializing 3D Engine
Script System Initialization
Entity system initialization
Initializing AI System
Config root path is: C:\Program Files (x86)\Electronic Arts\Crytek\Crysis Wars\mods\mwll
    $3e_view_dist_ratio = $6200 $5[]$4
    $3e_view_dist_custom_ratio = $6100 $5[]$4
    $3e_terrain_occlusion_culling = $61 $5[]$4
[PlayerProfiles] Login of user 'Benjamin' successful.
[PlayerProfiles] Found 2 profiles.
   Profile 0 : '[CW]Aresye'
   Profile 1 : 'default'
[GameProfiles]: Successfully activated profile '[CW]Aresye' for user 'Benjamin'
    $3r_FSAA = $60 $5[DUMPTODISK, REQUIRE_APP_RESTART]$4
    $3r_FSAA_samples = $60 $5[DUMPTODISK, REQUIRE_APP_RESTART]$4
    $3r_FSAA_quality = $60 $5[DUMPTODISK, REQUIRE_APP_RESTART]$4
Parsed 37 number of lines from Joystick.cfg before line error, returning.
Callback offset is 3128
    $3e_cbuffer = $61 $5[]$4
    $3e_detail_materials_view_dist_xy = $64096 $5[]$4
    $3e_detail_materials_view_dist_z = $61024 $5[]$4
    $3e_precache_level = $61 $5[]$4
    $3e_water_ocean_fft = $61 $5[]$4
    $3q_Renderer = $63 $5[]$4
    $3r_ColorGrading = $61 $5[]$4
    $3r_DepthOfField = $60 $5[]$4
    $3r_GeomInstancing = $61 $5[]$4
    $3r_sunshafts = $61 $5[]$4
    $3r_UseEdgeAA = $60 $5[]$4
    $3r_UsePOM = $60 $5[]$4
    $3s_FormatType = $63 $5[REQUIRE_APP_RESTART]$4
    $3s_MaxChannels = $6128 $5[DUMPTODISK]$4
    $3sys_physics = $61 $5[]$4
    $3sys_physics_CPU = $65 $5[]$4
    $3r_TexturesStreaming = $62 $5[REQUIRE_APP_RESTART]$4
    $3con_restricted = $60 $5[RESTRICTEDMODE]$4
    $3e_hw_occlusion_culling_objects = $60 $5[]$4
    $3e_hw_occlusion_culling_water = $61 $5[]$4
    $3e_recursion_occlusion_culling = $61 $5[]$4
    $3e_particles_thread = $61 $5[]$4
    $3e_terrain_occlusion_culling_version = $61 $5[]$4
    $3e_vegetation_static_instancing = $60 $5[]$4
    $3es_OnDemandPhysics = $60 $5[]$4
    $3gpu_particle_physics = $61 $5[REQUIRE_APP_RESTART]$4
[net 09:08:18.430] network hostname: Trueborn
[net 09:08:18.433]   ip:192.168.1.101
[net 09:10:09.594] connection requested to: <nat>10027300|162.244.26.113:64105
[net 09:10:16.467] resolved as: 162.244.26.113:64105
Game rules class: TestofStrength
    $3p_max_velocity = $61000 $5[]$4
ShowReviveCycle ignored (NULL)
Setting gametype to 'DeathMatch'
-----------------------------------------------------
*LOADING: Level Multiplayer/TSA/TSA_ClearCut loading time: 25.01 seconds
-----------------------------------------------------
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  r_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  l_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  r_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  l_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  r_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  l_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  r_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  l_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  r_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  l_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  r_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  l_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  r_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  l_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  r_root
[Error] Bone-names of SLAVE-skeleton don't match with bone-names of MASTER-skeleton:  l_root
[net 09:20:09.315] Disconnect c1106568-6526.cloudatcost.com:64105; profid=0; cause=19; msg='User left the game'
CGameClientChannel::Release
    $3r_FSAA = $60 $5[DUMPTODISK, REQUIRE_APP_RESTART]$4
    $3r_FSAA_samples = $60 $5[DUMPTODISK, REQUIRE_APP_RESTART]$4
    $3r_FSAA_quality = $60 $5[DUMPTODISK, REQUIRE_APP_RESTART]$4
[Warning] Unknown command: WarningBox
System:Quit

Offline Bruno_007

  • Apprentice Dev
  • Star Captain
  • *
  • Posts: 833
  • l33tp0intz: +90/-0
  • Osiris hats: sold out. ~Str1k3r
Re: Disconnected from server every 9min.
« Reply #4 on: August 29, 2014, 10:59:19 PM »
Meh, nothing interesting, just a msg='User left the game'.
Tools and I:
   - MWLL Online Launcher (LAN UDP Forwarder) - evolution of past "Le Proof of Concepto" project: connect without Gamespy via packet redirection;
   - Vehicle Browser - "Pocket Wiki" ©okaolias (not really that though);
   - Rconnect 4.3 - Server tools: map manager/player voting add-ons;
   - CryHammer - Validates Patch/CDKey of Crysis Wars (now unable to validate CDKey due to turned off Gamespy servers).

Offline [CW]Aresye

  • Star Captain
  • ***
  • Posts: 1005
  • l33tp0intz: +156/-1
  • Clan Wolf
    • Clan Wolf
Re: Disconnected from server every 9min.
« Reply #5 on: August 30, 2014, 01:16:22 AM »
Disabled the superfetch service to no avail.

It's very consistent at disconnecting at pretty much exactly 9m30s from the point I enter the game and have the team select window.

Definitely a software/service that's interfering.

Offline Bruno_007

  • Apprentice Dev
  • Star Captain
  • *
  • Posts: 833
  • l33tp0intz: +90/-0
  • Osiris hats: sold out. ~Str1k3r
Re: Disconnected from server every 9min.
« Reply #6 on: August 30, 2014, 02:30:49 AM »
You can use log_verbosity 4 to throw a bunch more text at your log file. Not sure if we'll understand what's happening through there though.
Tools and I:
   - MWLL Online Launcher (LAN UDP Forwarder) - evolution of past "Le Proof of Concepto" project: connect without Gamespy via packet redirection;
   - Vehicle Browser - "Pocket Wiki" ©okaolias (not really that though);
   - Rconnect 4.3 - Server tools: map manager/player voting add-ons;
   - CryHammer - Validates Patch/CDKey of Crysis Wars (now unable to validate CDKey due to turned off Gamespy servers).

Offline Spooky

  • Living Legend
  • *******
  • Posts: 3651
  • l33tp0intz: +158/-37
  • my little pwny
Re: Disconnected from server every 9min.
« Reply #7 on: August 30, 2014, 10:37:29 AM »
Disabled the superfetch service to no avail.

It's very consistent at disconnecting at pretty much exactly 9m30s from the point I enter the game and have the team select window.

Definitely a software/service that's interfering.

Or your router crapping out due to the large UDP packet sizes.

Do you use a Software Firewall? Have you restarted your Router yet?

Offline [CW]Aresye

  • Star Captain
  • ***
  • Posts: 1005
  • l33tp0intz: +156/-1
  • Clan Wolf
    • Clan Wolf
Re: Disconnected from server every 9min.
« Reply #8 on: August 31, 2014, 01:06:49 AM »
Well, turns out it definitely is the router.
*slaps head*
I completely overlooked checking that when troubleshooting, so when I plugged my computer directly into the cable modem, no more disconnects.  Yay!

Now to figure out which setting on the router is causing the issue.